require code for designing on EVE2-70A

FTDI/Bridgetek EVE2 & EVE3 SPI TFT Series by Matrix Orbital

Moderator: Mods

Henry
OMNIPRESENT
OMNIPRESENT
Posts: 2859
Joined: Tue Aug 14, 2001 6:00 pm
Contact:

Re: require code for designing on EVE2-70A

Post by Henry » Fri Sep 13, 2019 5:36 pm

madhusudan.jadhav,

At this point I would highly recommend trying this:

It will verify your screen is working as well as show you the code, including initialization.

https://github.com/MatrixOrbital/Basic-EVE-Demo
Henry J.
President
Matrix Orbital

madhusudan.jadhav
LCD!
Posts: 11
Joined: Wed Apr 03, 2019 11:24 am

Re: require code for designing on EVE2-70A

Post by madhusudan.jadhav » Fri Sep 20, 2019 4:03 pm

Hi Henry,
I used the code.Used library and configuration also and integrated it.the ValH is 0 and ValL 255. I changed the delay time several times
Last edited by madhusudan.jadhav on Sat Sep 21, 2019 10:16 am, edited 1 time in total.

Daniel Divino
Matrix Orbital
Matrix Orbital
Posts: 247
Joined: Thu Sep 24, 2015 9:38 am

Re: require code for designing on EVE2-70A

Post by Daniel Divino » Fri Sep 20, 2019 4:27 pm

Hi madhusudan.jadhav,

Which test executable are you running, and which display variant are you using?

Cheers,
Daniel
Daniel Divino
Technical Support
Matrix Orbital

madhusudan.jadhav
LCD!
Posts: 11
Joined: Wed Apr 03, 2019 11:24 am

Re: require code for designing on EVE2-70A

Post by madhusudan.jadhav » Sat Sep 21, 2019 10:20 am

Eve2_81x.h, MarixConf.h, Process.h. I am using EVE2-70A-TPR. I am trying to configure with xmc4500 relax kit. I am using xmc for Arduino code. i have manipulated for the project. I think due to no backlight the display isnot coming. because the display is always black. I am using external 3.3 volt to give supply to display. Also, the program goes at the end there no stucking anywhere. i am able to read reg_id.

Daniel Divino
Matrix Orbital
Matrix Orbital
Posts: 247
Joined: Thu Sep 24, 2015 9:38 am

Re: require code for designing on EVE2-70A

Post by Daniel Divino » Mon Sep 23, 2019 8:25 am

Hi madhusudan.jadhav,

I believe you mentioned you were trying out the Basic EVE Demo as a quick test to verify that your hardware works. Please note that the Basic EVE Demo was developed to run on an EVE display connected to a USB2SPI Bridge adapter.

Were you able to run the Basic EVE Demo properly on your EVE2-70A-TPR display? You mentioned that the ValH and ValL were not coming up properly. Were you running the EVE2_70A_TPR.exe, which is designed specifically for your display?

Cheers,
Daniel
Daniel Divino
Technical Support
Matrix Orbital

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests