Error Deploying

GTT Designer Software Support

Moderator: Mods

Post Reply
Haz
LCD Geek
Posts: 28
Joined: Wed Jun 28, 2017 8:52 am

Error Deploying

Post by Haz » Tue Sep 11, 2018 8:18 am

I am trying to deploy, and have a custom font, but the software keeps throwing an error for the standard font. How can i resolve this?
The messages get up in order as I have shown here.
Capture.PNG
Capture.PNG (16.56 KiB) Viewed 886 times
Capture1.PNG
Capture1.PNG (11.57 KiB) Viewed 886 times
When the deployment is done, I see the log, and shows that the 2 steps where this hangs still show copying vs. what all other files show as unchanged or done, etc..
Capture3.PNG
Capture3.PNG (8.24 KiB) Viewed 886 times
Any help to fix would be appreciated.

Thanks,
H-

Daniel Divino
Matrix Orbital
Matrix Orbital
Posts: 223
Joined: Thu Sep 24, 2015 9:38 am

Re: Error Deploying

Post by Daniel Divino » Tue Sep 11, 2018 9:51 am

Hi Haz,

According to the error messages, the GTT Designer cannot find the specified files/paths.

The first error states that the Designer can't find the LibraSansModern.ttf font at the path specified.
There are two solutions that I can suggest:
- You can change the font on all of the objects that use libra-sans-modern\LibraSansModern.ttf font
- You can navigate to your project's font folder (C:\Users\ehk\Documents\GitHub\CypressKillerMustang\GLCD\MustangElectronicDisplay_SystemManagement\Assets\Fonts) and drop a copy of the LibraSansModern.ttf font in the libra-sans-modern folder.

I haven't been able to replicate your second error. Is it possible for you to email me you project so that I can test it here to figure out what might be causing the issue?

You can email your project to support@matrixorbital.ca

Thanks,
Daniel
Daniel Divino
Technical Support
Matrix Orbital

Haz
LCD Geek
Posts: 28
Joined: Wed Jun 28, 2017 8:52 am

Re: Error Deploying

Post by Haz » Tue Sep 11, 2018 3:38 pm

I was able to fix the first one as you stated. I will send my project to the email provided for any help you can give me on the second one.

Thanks,
H-

Daniel Divino
Matrix Orbital
Matrix Orbital
Posts: 223
Joined: Thu Sep 24, 2015 9:38 am

Re: Error Deploying

Post by Daniel Divino » Wed Sep 12, 2018 4:02 pm

Hi Haz,

I received your project and we're currently looking into what might be causing the issue!

Thanks,
Daniel
Daniel Divino
Technical Support
Matrix Orbital

Daniel Divino
Matrix Orbital
Matrix Orbital
Posts: 223
Joined: Thu Sep 24, 2015 9:38 am

Re: Error Deploying

Post by Daniel Divino » Thu Sep 13, 2018 12:40 pm

Hi Haz,

We were able to take a look at your project, and we found that two of your labels were not using valid fonts, and their font fields were left blank. Please try pointing to a valid font. That should allow you to deploy your project without receiving any unwanted errors messages.

Thanks,
Daniel
Daniel Divino
Technical Support
Matrix Orbital

Haz
LCD Geek
Posts: 28
Joined: Wed Jun 28, 2017 8:52 am

Re: Error Deploying

Post by Haz » Thu Sep 13, 2018 1:01 pm

I just went through my project and found where the font was blank.

Thanks for the help.
H-

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest