OK204-25 keep sending K letter

LK/ELK/VK/PK/OK/MX/GLK/EGLK/GVK/GLT Series

Moderators: Henry, Mods

Post Reply
luis.taboada
LCD?
Posts: 4
Joined: Fri Oct 05, 2018 2:55 pm

OK204-25 keep sending K letter

Post by luis.taboada » Tue Jan 22, 2019 7:46 pm

Hi, I have 2 OK204-25 (RS232) but one keeps sending the K letter, even if no keyboard is attached. the display is working fine.

I send the command FE 60 and it stops, then I attached a keyboard and when I press keys, some times got the rigth key and some times the "K", So I change the keyboard and it was the same problem.

I try the manual override change the parameters but I cant get it work rigth.

Thanks for any advise.

Daniel Divino
Matrix Orbital
Matrix Orbital
Posts: 247
Joined: Thu Sep 24, 2015 9:38 am

Re: OK204-25 keep sending K letter

Post by Daniel Divino » Wed Jan 23, 2019 10:43 am

Hi Luis,

What happens when only power is connect to display? If the display is only connected to power, and no data is being sent to the unit, are 'K' characters still appearing on screen?

Also, 'K' has an ASCII DEC value of 107. Are you sending a DEC 107 to the display at any point during operation?

Cheers,
Daniel
Daniel Divino
Technical Support
Matrix Orbital

luis.taboada
LCD?
Posts: 4
Joined: Fri Oct 05, 2018 2:55 pm

Re: OK204-25 keep sending K letter

Post by luis.taboada » Wed Jan 23, 2019 12:18 pm

The OK204-25 is sending the "K" Character to the serial port and even if there is no keypad connected.
It was working correctly.

Daniel Divino
Matrix Orbital
Matrix Orbital
Posts: 247
Joined: Thu Sep 24, 2015 9:38 am

Re: OK204-25 keep sending K letter

Post by Daniel Divino » Fri Jan 25, 2019 2:35 pm

Hi Luis,

Could you take a picture of the back of the display, along with a picture of the keypad header itself, and send it to me?

Cheers,
Daniel
Daniel Divino
Technical Support
Matrix Orbital

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests