Page 1 of 1

Mogd# Upload Font Problems

Posted: Sat Apr 07, 2018 5:15 pm
by bubbletea

Here's my device and setup:
  • GLK240128-25 PCB 1.1
    Firmware: 0x54
    RS232 Mode
    Mogd# 1.1.8
    Windows 10 Pro (64-bit)
I've recently wiped the module file system on my display and am having problems re-uploading font to the device. Each time I try to upload any font, I get the error message "There was a problem uploading the font to the device.". I've installed the "SmallFilled" and "Futura" fonts provided by the MO download site, and copied them to "%AppData%\Roaming\MogdShapFonts". The Mogd# program is installed to my "C:\Temp" directory so no permission issues there. Any suggestions would be much appreciated.


Re: Mogd# Upload Font Problems

Posted: Sat Apr 07, 2018 8:12 pm
by bubbletea
So I found a working solution. I was able to dig up an old (very) version of MogdSharp (version 1.0.7) that I had. I used the following settings with the older version of Mogd# and the upload was successful even though the model and PCB version is different that what I actually have.
  • Display Type GLK24064-25
  • PCB Revision: 2.0
I tried the same configuration above with MogdSharp 1.1.8 for my GLK240128-25 PCB 1.1 LCD and the upload still fails. It also fails in 1.1.8 when I select the correct model and pcb rev as well. I guess the older displays are not too well supported.

Re: Mogd# Upload Font Problems

Posted: Mon Apr 09, 2018 9:23 am
by Daniel Divino
Hi Bubbletea,

Welcome to the Forums!

I understand you were experiencing a few issues uploading fonts to your PCB Rev 1.1 GLK240128 this weekend. It sounds like you were able to find a workaround and you were able to upload the fonts you needed onto your display, but I wanted to know a couple things about your setup.

When running Mogd# 1.1.8, were you able to autodetect your connected display? Also, prior to uploading your font, were you able to send text strings, and clear the display screen?

Daniel Divino

Re: Mogd# Upload Font Problems

Posted: Mon Apr 09, 2018 2:18 pm
by bubbletea

Thanks for the response! Yes, using 1.1.8, the software detected the display model and version correctly. Other basic controls functionality like drawing, text, backlight, and contrast, all worked! It was just the uploading of fonts that consistently failed.


Re: Mogd# Upload Font Problems

Posted: Tue Apr 10, 2018 8:55 am
by Daniel Divino
Hi bubbletea,

Could you provide a few more details about the failure? Do you know specifically when the upload fails, or what error pops up?

Also, are you able to read data from the display? In MOGD# you'll find read revision and read customer data command controls in Configuration>Configure Display Defaults.


Re: Mogd# Upload Font Problems

Posted: Fri Dec 07, 2018 5:27 am
by Dilipkumar
Hi ,
I am also spacing same problem in my device could please share Mogd# 1.1.7 older version link