Page 1 of 1

GPO Problem on glk19264-7t-1u

Posted: Sat Jul 04, 2009 9:32 am
by gazrhys
I'm communicating successfully with the display using i2c (from an arduino).
I am able to display text and graphics, change brightness and contrast, but I can't change the gpo state.
The gpo LEDs stay on despite sending the off command (254, 86, gpo num).
Am I missing something?

Any help would be appreciated as it's driving me insane!

Posted: Sat Jul 04, 2009 12:10 pm
by Ray
That should actually do the trick, make sure you send 0x00 ('\0') for gpo 0 and not 0x30 ('0') if you use any of the other GPO command such as setting the startup state does that work?

Posted: Sat Jul 04, 2009 2:30 pm
by gazrhys
None of the GPO commands are working, but everything else does.
The LEDs are always on.
I've tried sending the command numbers in decimal and hex.

I'm using the wiring library on the arduino with the following code.


I've also tried adding various delays to no avail. Is there anything else I can try, or do I have a hardware problem?

Thanks for the help!

Posted: Sat Jul 04, 2009 3:22 pm
by Ray
I got nothing for you at this moment, however i'll point out this thread monday to a more knowlegable person on this subject who'll be able to figure out whats going on here.

Posted: Mon Jul 06, 2009 9:25 am
by Clark
Hi gazrhys,

Unfortunately, our GPO numbering starts at 1, so I don't believe toggling GPO 0 will have any effect. Also, this may sound a little crazy unless you've read through the manual, but try turning GPO 1 and 2 on. There are a few tables on page 35 that outline our slightly confusing control scheme for the three bi-color LEDs onboard.

If you have any further trouble, please don't hesitate to put up another post.


Re: GPO Problem on glk19264-7t-1u

Posted: Mon Aug 22, 2016 6:08 am
by Spikedsoft
I found this thread because i had a similar problem.
If anyone else finds this and has a problem enabling the GPO pins, here is what you have to consider:

The first 6 GPO numbers are reserved for the front LEDs.
If you want to enable GPO1 from the GPO Header you have to actually send the number 7 in the command.