Search found 5 matches

by PaulP
Thu Aug 22, 2019 7:56 am
Forum: EVE2 & EVE3 SPI TFT's
Topic: EVE2-43G brightness increase possible?
Replies: 1
Views: 408

EVE2-43G brightness increase possible?

After getting the EVE2-43G display working, I presented it to potential users, and their first comment was "can you increase the brightness?" And yes, actually, though I have not measured it, it is notably dimmer than other similar LCDs, e.g. my phone. I am running it with a measured 3.28V on both p...
by PaulP
Mon Aug 19, 2019 12:21 pm
Forum: EVE2 & EVE3 SPI TFT's
Topic: EVE2-43G intialization difficulty
Replies: 7
Views: 1176

Re: EVE2-43G intialization difficulty

Thanks. Good to know the EVE3 can have alternate backlight power. But looking at its schematic, it looks like the BL_VDD that would go on pins 17&18 is the actual raw backlight anode voltage (so, around 20V?), not 3.3V. This (it looks like) is a huge difference from the EVE2 function on the same pin...
by PaulP
Mon Aug 19, 2019 7:07 am
Forum: EVE2 & EVE3 SPI TFT's
Topic: EVE2-43G intialization difficulty
Replies: 7
Views: 1176

Re: EVE2-43G intialization difficulty

Thanks Daniel. It's (more or less) solved now. Here's the story: After too much frustration with this I got the USB2SPI interface as you suggested. After the expected delays and frustration with Visual Studio I did get the examples running, showing the display works fine. I put a logic analyzer on t...
by PaulP
Thu Aug 08, 2019 12:06 pm
Forum: EVE2 & EVE3 SPI TFT's
Topic: EVE2-43G intialization difficulty
Replies: 7
Views: 1176

Re: EVE2-43G intialization difficulty

Thanks Daniel. Here's the schematic of my setup: EVE2-Proto1.png DC power at 5V comes in through the USB on the Teensy. Even though the Teensy can supply 3.3V from its on-board regulator, the 200 mA+ the display is likely to draw is pushing its capability, so that's why the additional regulator. The...
by PaulP
Thu Aug 08, 2019 7:58 am
Forum: EVE2 & EVE3 SPI TFT's
Topic: EVE2-43G intialization difficulty
Replies: 7
Views: 1176

EVE2-43G intialization difficulty

I had good results with the EVE (801) 5" display previously, so for a new project decided to use the EVE2-43G, but having great problems getting it even to initialize. It appears dead. Is it just a problem with my initialization method, or do I have a DOA lemon? I'm using the Matrix Orbital Eve2_81x...