LCD motorbike gauge problems.

Take a load off and chat!

Moderators: Henry, Mods

Post Reply
Thruan
LCD?
Posts: 3
Joined: Wed Jan 25, 2012 3:39 pm

LCD motorbike gauge problems.

Post by Thruan » Wed Jan 25, 2012 3:50 pm

Hi all.

First post so go easy on me :D

I have a set of gauges from my motorbike, long story short, water got into the gauges and now i have a problem.

my temp display now only shows the first of 3 digits.. that 1 digit works perfectly fine. but the others arent there at all. the rest of the display (the bits that the gauges run like speedo and stuff) work perfectly fine, its just the 2 digits of the temp.

I cant tell you what brand/model the LCD is, but its a matrix screen, about 3 inches by 2, and instead of hard terminals, it has a rubberish strip along the back that pushes against the PCB contacts and the 'wires' run inside the rubber bit. dont know if that means anything to you guys though. It has 2 sets of 12 contacts for the LCD.

I have stripped the gauges right down, cleaned up some corrosion on some of the solider points, and removed a white power substance from the LCD contacts on the PCB side, reassembled and still no luck.

Can you guys suggest anything for me to check/lookat, or thoughts on what could be causeing it?

Thruan
LCD?
Posts: 3
Joined: Wed Jan 25, 2012 3:39 pm

Post by Thruan » Wed Jan 25, 2012 3:50 pm

Oh, sorry if this is in the wrong place, but i dont know which forum to put it in.

Thruan
LCD?
Posts: 3
Joined: Wed Jan 25, 2012 3:39 pm

Post by Thruan » Wed Jan 25, 2012 4:42 pm

correction, its not a matrix, it is infact a character display. just a custom made one it seems.

After more investigation, it seems where the rubber contact strip thing meets the glass is coming apart/has moisture in it..

Does anyone have any experience with an LCD like this?

Oh, if it matters its off an 05 Mv Agusta Brutale.

Clark
Matrix Orbital
Matrix Orbital
Posts: 864
Joined: Fri Aug 17, 2007 10:58 am
Location: Matrix Orbital
Contact:

Post by Clark » Fri Jan 27, 2012 9:11 am

Hi Thruan,

Unfortunately, this is a forum primarily for Matrix Orbital displays, I don't expect you'll find much support for your damaged custom screen.

Knowing nothing of the circuitry involved, I would recommend looking at those rubber "zebra" strips; they'll connect the glass to the PCB and can be quite finicky. Make sure they are clean of moisture and dirt, seated correctly on the glass, and make a good connection to the PCB.

Best of luck,
Troy
Troy Clark
Design & Development
Matrix Orbital

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest