LCD0821 problem

Take a load off and chat!

Moderators: Henry, Mods

Post Reply
IanJ
LCD?
Posts: 3
Joined: Sun May 02, 2010 1:04 pm

LCD0821 problem

Post by IanJ » Sun May 02, 2010 1:10 pm

Hi all,

Just bought an LCD0821, latest versions I believe.

It has been working fine, however, the problem I have is as follows:-

I have it connected to an Arduino in RS232 TTL mode. Nowe, when I send new code to my Arduino via the Usb port it also repeats the data on the RS232 TTL output.......the net result is that when updating code on the Arduino the LCD0821 will flash up all sorts of stuff until the comms is done.
Usually at that point when the Arduino re-boots all is fine and the LCD0821 is fine.

However, sometimes the LCD0821 doesn't startup, the display stays completely blank and the only thing that works is the control codes for the likes of brightness etc.

Also, sometimes it's not completely blank, maybe row 1 & col 1 are able to be written to, the rest stays blank.

I have the link fitted that sets the display to factory defaults.

This has happpened a few times and the only way to fix is to keep uploading new code to the Ardiono in the hope that the display "resets" itself.

I notice that when the LCD was working fine when I power up I'd get some random characters on the display before my comms starts........but now it's completely blank. Is this significant?

I have tried setting the data unlock level to 0 in my Arduino code....no luck.
Whilst I am on this, the manual has me confused in regard to datalock.
254 202 245 160 [level]
or
254 203 245 160 [level]
Difference here?

Any ideas?......maybe I need to reset the character set....how?

Ian.

IanJ
LCD?
Posts: 3
Joined: Sun May 02, 2010 1:04 pm

Post by IanJ » Mon May 03, 2010 12:56 am

UPDATE 3/5/10:-

Well no matter what I do I can't get it to work this time. Looks like it's bricked! I just wonder if there is some undocumented cobtrol code that can completely reset the display to factory defaults, including everything?
I feel there has to be, because it struck me that is what possibly happens when I keep uploading my Arduino with any code and the Lcd suddenly starts working again, i.e. I randomly hit on a certain control sequence.

I have tried everything in the manual, all the control codes for all sorts....but no luck.

Ian.

Clark
Matrix Orbital
Matrix Orbital
Posts: 864
Joined: Fri Aug 17, 2007 10:58 am
Location: Matrix Orbital
Contact:

Post by Clark » Mon May 03, 2010 9:21 am

Hi Ian,

It sounds like you have had some Arduino updates going through to your LCD0821 which is now rather lifeless. First up, sending characters not specifically formatted for the LCD is not recommended because, well, it's difficult to figure out what the LCD is being told to do, and what it may have done incorrectly.

That said, with power cycled to the unit while the override connector is on, all defaults should be reset. I have found that sending large amounts of information quickly, especially when it is not formatted for the LCD, can corrupt the actual code in the controller itself. If that happens the override won't help.

Finally, in terms of code, 202 will set the lock until power is cycled while 203 will set and save the lock indefinitely, throughout any power cycle. As for resetting the unit, unfortunately, there is nothing documented or otherwise that will do this through software; the hardware reset was felt to be sufficient.

All the best in development with the tips above, however, if you still continue to have trouble feel free to throw up another post for help or send over a PM for information on obtaining an RMA for repair.

~Troy
Troy Clark
Design & Development
Matrix Orbital

IanJ
LCD?
Posts: 3
Joined: Sun May 02, 2010 1:04 pm

Post by IanJ » Mon May 03, 2010 11:34 am

Troy,

Thanks for the info.

Do any of the apps like uProject etc work with the LCD0821, i.e. is it possible to flash the LCD with the original firmware, and is the original firmware available to download?

Ian.

Clark
Matrix Orbital
Matrix Orbital
Posts: 864
Joined: Fri Aug 17, 2007 10:58 am
Location: Matrix Orbital
Contact:

Post by Clark » Mon May 03, 2010 2:29 pm

Hi Ian,

No worries, the best uProject can do is reset all of the default settings, provided communication can be proven successful; unfortunately, the code inside the controller is locked and can only be reset at our facility.

If you continue having trouble with the LCD0821 and are unable to get any response out of it, let me know and we may have to look at an RMA.

~Troy
Troy Clark
Design & Development
Matrix Orbital

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests