BAD Print UTF-8 in GTTProject

GTT TFT Support

Moderator: Mods

Post Reply
djvoss
LCD!
Posts: 13
Joined: Thu Jul 10, 2014 8:49 am

BAD Print UTF-8 in GTTProject

Post by djvoss » Sat Jul 19, 2014 2:18 pm

When I use Print UTF-8 String the RAW DATA shows the following: 255 37 and no data ( char data ). No chars are displayed on the screen. I did proceed this command with a load font, set font, and set font size and color.

Help please

Don

Tino
Matrix Orbital
Matrix Orbital
Posts: 158
Joined: Wed May 22, 2013 9:04 am
Location: Matrix Orbital
Contact:

Re: BAD Print UTF-8 in GTTProject

Post by Tino » Mon Jul 21, 2014 9:30 am

Hi Don,

How are you sending the data to your display?

Are you sending a UTF-8 formatted string when you send the data?

Thank you
Martino
Martino DeLeon
Matrix Orbital
Technical Support Representative

djvoss
LCD!
Posts: 13
Joined: Thu Jul 10, 2014 8:49 am

Re: BAD Print UTF-8 in GTTProject

Post by djvoss » Mon Jul 21, 2014 10:26 am

Martino,
I am using your GTT Project Software. When I try to use the Print UTF-8 command, the raw data displayed has no char data. After execution the interaction panel also shows that no data is send after the 255 37 . If I use the other Unicode String, it works. however I would like to setup an ascii string.
Thanks,
Don

Tino
Matrix Orbital
Matrix Orbital
Posts: 158
Joined: Wed May 22, 2013 9:04 am
Location: Matrix Orbital
Contact:

Re: BAD Print UTF-8 in GTTProject

Post by Tino » Mon Jul 21, 2014 10:58 am

Hi Don,

I will look into this for you. In the mean time is it possible you use the "Print Unicode String" command?

Thank you
Martino
Martino DeLeon
Matrix Orbital
Technical Support Representative

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests