I2C Stops Working

GTT TFT Support

Moderator: Mods

Post Reply
iotexpert.com
LCD!
Posts: 16
Joined: Fri Apr 27, 2018 9:15 am

I2C Stops Working

Post by iotexpert.com » Sun Apr 29, 2018 5:07 pm

I am able to talk to the GTT43A via Serial and via the Mass Storage.

I am no longer able to talk via I2C.

For the life of me I can't figure out what I could have done to turn off the I2C.

Does anyone have any idea?

Daniel Divino
Matrix Orbital
Matrix Orbital
Posts: 120
Joined: Thu Sep 24, 2015 9:38 am

Re: I2C Stops Working

Post by Daniel Divino » Mon Apr 30, 2018 9:55 am

Hi iotexpert,

Are you unable to read and write data to the display at all? When a clear screen command (254 88) is sent to the GTT, does it respond at all?

Cheers,
Daniel Divino
Daniel Divino
Technical Support
Matrix Orbital

iotexpert.com
LCD!
Posts: 16
Joined: Fri Apr 27, 2018 9:15 am

Re: I2C Stops Working

Post by iotexpert.com » Mon Apr 30, 2018 1:36 pm

I can still write to it via the serial port... yes... using the UART I can send 254 88 and I get a clear screen... and I can read as well.

What I cannot do is talk to the display via I2C.

All writes and reads of the device are NAK

I suspected that it might be a power problem (from another thread) so I connected to a big external supply... when I did this, it fixed other problems that I was having... but the I2C still doesn't work.

I am assuming that there is some configuration setting that I did that break it... but when I remove autoexec that doesnt fix it... new firmware doesnt fix it... old firmware doesnt fix it...

When I connect the logic analyzer I can see the writes are happening correctly from the PSoC development kit that I am driving the display with... but no response... only a sea of NAKs

I suppose that I might have blown up that port? It is frustrating (as you can tell by my other post that I got the I2C working earlier in the weekend)

Alan

Daniel Divino
Matrix Orbital
Matrix Orbital
Posts: 120
Joined: Thu Sep 24, 2015 9:38 am

Re: I2C Stops Working

Post by Daniel Divino » Tue May 01, 2018 9:11 am

Hi Alan,

Have you changed the GTT's i2c address at all? Also, are pull-ups present on both the SCL and SDA line?

Cheers,
Daniel
Daniel Divino
Technical Support
Matrix Orbital

iotexpert.com
LCD!
Posts: 16
Joined: Fri Apr 27, 2018 9:15 am

Re: I2C Stops Working

Post by iotexpert.com » Tue May 01, 2018 11:19 am

Yes I have tried multiple I2C addresses.

Yes I have 2.2K pull-ups... (it was working).

Is there some setting that turns I2C on/off in the screen? Could I have changed something?

At this point all I can figure is that I blew up something.

Alan

iotexpert.com
LCD!
Posts: 16
Joined: Fri Apr 27, 2018 9:15 am

Re: I2C Stops Working

Post by iotexpert.com » Thu May 03, 2018 9:40 am

Well.

I got a new display today. I plugged it into the same setup and it works.

I suppose my other one has a blown up I2C... which sucks

How do I RMA it?

Alan

iotexpert.com
LCD!
Posts: 16
Joined: Fri Apr 27, 2018 9:15 am

Re: I2C Stops Working

Post by iotexpert.com » Wed May 09, 2018 4:01 pm

Turns out that there is some bug in 2.10xx firmware... and in fact 2.9xxx firmware.

A workaround to unbrick the display is to install 2.4 firmware... then reinstall 2.10

Daniel Divino
Matrix Orbital
Matrix Orbital
Posts: 120
Joined: Thu Sep 24, 2015 9:38 am

Re: I2C Stops Working

Post by Daniel Divino » Thu May 17, 2018 11:05 am

Hi Alan,

I'll do additional testing with a GTT running the most recent firmware release to see if I can brick the i2c port.

Cheers,
Daniel
Daniel Divino
Technical Support
Matrix Orbital

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest