Beginner question, Powering up MOP-AL162a

Support for MOC/MOS/MOI/MOU/X-Board/MOP

Moderator: Mods

Post Reply
RickN
LCD?
Posts: 3
Joined: Fri Oct 02, 2009 3:17 am

Beginner question, Powering up MOP-AL162a

Post by RickN » Fri Oct 02, 2009 3:32 am

Hi,

Could someone tell me what I'm doing wrong? I'm trying to power up a MOP-AL162a LCD but nothing is happening. I guess the wiring is wrong. I never did electronics before (except letting a LED burn via a Microcontroller) so forgive me.

Here's the situation, I have an Arduino Microcontroller connected with my computer. The MC has a 5Volt output and ground that go the LCD. The first question arises here:
- Is the power given by the computer (via USB) enough to power up the LCD? I don't have an external 9 Volt supply yet, only 5 Volt.

I didn't connect the databits yet, just wanted to see the LCD powering up. So,
LCD pin 1 (Vss) --> directly to the MC ground
LCD pin 2 (Vdd) --> directly to the MC 5 Volt
LCD pin 3 (V0, contrast) --> directly connected to the MC 5 volt, I don't have a potmeter yet... Should this also get connected to the ground?

I don't have anything else connected so far, but I see there is also a "Chip Enable" on pin 6. Do I need to send 5 Volt to this pin as well before anything happens?


The LCD has 2 rows of 16 pins, I guess it doesn't matter to which row I connect my cables but I could be very wrong of course. So far I only used the row at the bottom. I haven't soldered anything yet as well, all 16 pins lie on a male header strip. So maybe the LCD is not even making proper contact. I can let a LED burn on these pins though, so the ground and 5 volt is on these header pins.

Excuse me if I asked stupid questions, but it's my very first time!
And sorry if I can't reply, I'm going on a little vacation later today :)

Rick

Raquel
Matrix Orbital
Matrix Orbital
Posts: 689
Joined: Thu Aug 19, 2004 3:37 pm
Location: MO Office

Post by Raquel » Fri Oct 02, 2009 9:42 am

Hi,

Thank you for posting on the forum.

Yes, you have the connections correct:
LCD pin 1 (Vss) --> ground
LCD pin 2 (Vdd) --> 5V

As per pin 3, connect it to ground for now. At ground level, when you write characters to the display, you should be able to see them, ie. contrast is just right, not too light, nor too dark.

Yes, there are two 1x16 headers, and you will only need to connect to one of them. You will need to connect to the control and data lines, ie D0-D7 (or just D4 to D7 if you want to go to the 4 line interface) and the RS, R/W, E lines. You will have to control those lines, and here is the datasheet you need to consult in doing that. If you need the backlight, you will need to connect to pins 15 and 16 as well.

I hope this helps.

Best Regards,
Raquel Malinis
Design and Development
Matrix Orbital

RickN
LCD?
Posts: 3
Joined: Fri Oct 02, 2009 3:17 am

Post by RickN » Mon Oct 05, 2009 5:55 am

Hi again,

I wired the board as being told, but still nothing happens. What should happen when I power the LCD up? I guess I should at least see the screen brighten up, maybe with some blocks printed?

Anyhow, Pin1 & 3 are on the ground, pin2 on the 5Volt. R/W is to the ground as well (I only need to write). Enable, RS and databit 4..7 are connected to digital outputs on the Arduino MC.

As I said, I have zero experience with electronics so maybe something else is wrong:
- MC is powered via the Laptop USB. Maybe it has not enough to power the LCD?
- The LCD is lying on a male 16 pins header. I didn't solder anything so maybe it\s not making proper contact?

Rick

Raquel
Matrix Orbital
Matrix Orbital
Posts: 689
Joined: Thu Aug 19, 2004 3:37 pm
Location: MO Office

Post by Raquel » Mon Oct 05, 2009 9:31 am

Hi,

If you have pins 15 and 16 wired up, and then power the display, you will see the backlight turn on. But having the rest wired up will not give you anything (even blocks) on the screen. Again, you will need to communicate with the display using the data and control lines. Please see page 46 of this datasheet for the initialization instructions.

Power from the USB should be enough for the LCD; but if you want to make sure, you probably want to power from another power supply. I do not know how much power your Arduino board takes.

You will need to program up the Arduino to talk to the display using the guidelines in the linked data sheet.

Good luck,
Raquel Malinis
Design and Development
Matrix Orbital

RickN
LCD?
Posts: 3
Joined: Fri Oct 02, 2009 3:17 am

Post by RickN » Mon Oct 05, 2009 10:19 am

Allright. The MC already runs a program that should drive a LCD that uses the "Hitachi HD44780" driver, but I'll check the code with the datasheet anyway.

As for the backlight, how do I connect these 2 pins... LED+ to 5Volt and LED- to the ground?

Thanks for helping!
Rick

Raquel
Matrix Orbital
Matrix Orbital
Posts: 689
Joined: Thu Aug 19, 2004 3:37 pm
Location: MO Office

Post by Raquel » Mon Oct 05, 2009 10:26 am

Yes, that is correct, 5V to LED+ and 0V to LED-

Oh and sorry about the 'no blocks' if you have pin 3 to 0V, and if the display is still alive, you should see a very faint 1 row of blocks. (Thanks to Ray for correcting me on this).
Raquel Malinis
Design and Development
Matrix Orbital

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest