LK204-25 Blinking Block and Underline Cursor

LK/ELK/VK/PK/OK/MX/GLK/EGLK/GVK/GLT Series

Moderators: Henry, Mods

Post Reply
frank
LCD?
Posts: 5
Joined: Wed Sep 30, 2015 7:01 pm

LK204-25 Blinking Block and Underline Cursor

Post by frank » Wed Sep 30, 2015 7:41 pm

For some reason my display doesn't respond properly to the command to turn on and off the blinking block cursor or the underline cursor. I'm using i2c, and I can move the cursor around, write to the display, clear the display, turn off the display, adjust the brightness, read keypad presses etc., but sending 254 83, 254 84, 254 74, or 254 75 does not do what it should: it does nothing, sends extraneous spaces, clears the display, or locks up the display (which requires a power cycle to get it to function again). I've obtained the same results using a Basic Stamp 2pe and Propeller microcontroller.

I know that in the past there was a memory chip firmware issue that caused a similar issue for the LK202-25 (viewtopic.php?f=1&t=1474). Could this be the case with my display? Is there anything that I can do to fix this problem?

Daniel Divino
Matrix Orbital
Matrix Orbital
Posts: 92
Joined: Thu Sep 24, 2015 9:38 am

Re: LK204-25 Blinking Block and Underline Cursor

Post by Daniel Divino » Thu Oct 01, 2015 10:39 am

Hello Frank,

I understand you are having issues getting the Underline Cursor and the Blinking Block commands to work with your LK204-25 display. Before we can attempt to resolve the issue I would like to replicate it in house. Can you tell me what Firmware and PCB rev you are using?

Thanks,

Daniel Divino
Daniel Divino
Technical Support
Matrix Orbital

frank
LCD?
Posts: 5
Joined: Wed Sep 30, 2015 7:01 pm

Re: LK204-25 Blinking Block and Underline Cursor

Post by frank » Thu Oct 01, 2015 12:33 pm

I have PCB v3.0, and I think the firmware is 7.1:

To rule out any issues with programming, I switched the jumpers from i2c to rs232 and used the uProject program. The display responds to brightness, text entry, as before, and acts in the same incorrect way when I try to toggle the cursors. The version number returns 71. However, if I check the serial number first, the version number returns a different number every time: 00, 09, 99, FE, ... The same is true for the module type: it returns "LK204-25", but if I check the serial number first, it simply returns " ".

Daniel Divino
Matrix Orbital
Matrix Orbital
Posts: 92
Joined: Thu Sep 24, 2015 9:38 am

Re: LK204-25 Blinking Block and Underline Cursor

Post by Daniel Divino » Thu Oct 01, 2015 2:27 pm

Hello Frank,

I attempted to replicate the issues you are facing with your LK204-25. Using the same firmware and PCB rev, I did not face any issues getting the underline cursor command or the blinking block command to work. This may mean that your board has a defect. In order to confirm this I am sending you a script to run in uProject. This was the script I had run on my display and it returned proper results. Please run this script and tell me if anything changes

Once you download the .txt file you can change it into a .usf by renaming the file, and replacing the ".txt" with a ".usf". You should then be able to open the script in uProject.

Thanks,

Daniel
Attachments
LK204-25 command debug.txt
(333 Bytes) Downloaded 43 times
Daniel Divino
Technical Support
Matrix Orbital

frank
LCD?
Posts: 5
Joined: Wed Sep 30, 2015 7:01 pm

Re: LK204-25 Blinking Block and Underline Cursor

Post by frank » Thu Oct 01, 2015 3:40 pm

Hi Daniel,

I ran the script but the display didn't show any cursor. And afterwards, I needed to power cycle the display to send text to it again. uProject returned the message: "Module's serial number is 0xFE 0x99" and said that the display returned

0xFE 0x99 0xFF 0x00 0xFE
0x99 0x00 0x00 0xFE 0x99
0x00 0x00 0xFE 0x58 0x00
0xFE 0x71 0x09

and that there were no errors. Nevertheless, the display didn't return the proper results.

I also noticed that the large numbers in the display are corrupted. In fact, they look the same as what another user has reported once (see the photo in this thread viewtopic.php?f=1&t=4676&hilit=uProject ... y&start=15).

Thanks for your help.

Daniel Divino
Matrix Orbital
Matrix Orbital
Posts: 92
Joined: Thu Sep 24, 2015 9:38 am

Re: LK204-25 Blinking Block and Underline Cursor

Post by Daniel Divino » Thu Oct 01, 2015 4:25 pm

Hi Frank,

It seems like your EEPROM is having issues. We should have a file that can be used to reset the EEPROM. I'll be able to send the file as well as a couple instructions tomorrow.

Best regards,

Daniel Divino
Daniel Divino
Technical Support
Matrix Orbital

frank
LCD?
Posts: 5
Joined: Wed Sep 30, 2015 7:01 pm

Re: LK204-25 Blinking Block and Underline Cursor

Post by frank » Thu Oct 01, 2015 4:56 pm

OK perfect. Thanks.

Daniel Divino
Matrix Orbital
Matrix Orbital
Posts: 92
Joined: Thu Sep 24, 2015 9:38 am

Re: LK204-25 Blinking Block and Underline Cursor

Post by Daniel Divino » Fri Oct 02, 2015 8:54 am

Hello Frank,

Attached is the file that'll reset your EEPROM back to default. Just unzip the folder and upload the MEM File to your display with the "upload memory" command in uProject. Tell me if any problems remain.

Thanks,

Daniel Divino
Attachments
LK204-25 G2 mem.zip
(378 Bytes) Downloaded 46 times
Daniel Divino
Technical Support
Matrix Orbital

frank
LCD?
Posts: 5
Joined: Wed Sep 30, 2015 7:01 pm

Re: LK204-25 Blinking Block and Underline Cursor

Post by frank » Fri Oct 02, 2015 12:14 pm

Thanks Daniel. This resolved the issue. Your support is top-notch.

Daniel Divino
Matrix Orbital
Matrix Orbital
Posts: 92
Joined: Thu Sep 24, 2015 9:38 am

Re: LK204-25 Blinking Block and Underline Cursor

Post by Daniel Divino » Fri Oct 02, 2015 1:21 pm

I'm glad to hear that it's working! Thanks :)

Take care,

Daniel Divino
Daniel Divino
Technical Support
Matrix Orbital

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests