LK204-25 strange characters

LK/ELK/VK/PK/OK/MX/GLK/EGLK/GVK/GLT Series

Moderators: Henry, Mods

Post Reply
MarioAtJazz
LCD?
Posts: 4
Joined: Sat Feb 28, 2015 8:04 pm

LK204-25 strange characters

Post by MarioAtJazz » Sat Feb 28, 2015 8:28 pm

I have a brand new LK204-25 connected to a PC and i send characters with HYPERTERM as described in the manual.
When i send a character the display shows sometimes the correct character, sometimes a strange one.
e.g.

"mario eduardo" will be display correct
"mario eduardooooo" will display "mario eduardoo?o?"
in the line above the '?' means that a character similar to an 'o' is diplayed

"mamaaaaaaaa" will display "mamaa?a?a?a"
in the line above the '?' means that a character similar to an 'y' is diplayed

It seems like a problem with repeating characters

any idea ?
Thx, Mario

Clark
Matrix Orbital
Matrix Orbital
Posts: 861
Joined: Fri Aug 17, 2007 10:58 am
Location: Matrix Orbital
Contact:

Re: LK204-25 strange characters

Post by Clark » Mon Mar 02, 2015 8:04 am

Hello Mario,

When communicating to the display, please ensure you are using 8 bits data, no parity, and 1 stop bit. You might also try using a shorter cable and ensuring your host and the display have a common ground connection.

Cheers,
Troy
Troy Clark
Design & Development
Matrix Orbital

MarioAtJazz
LCD?
Posts: 4
Joined: Sat Feb 28, 2015 8:04 pm

Re: LK204-25 strange characters

Post by MarioAtJazz » Mon Mar 02, 2015 1:51 pm

i reduced the lenght of the cable to 20cm,
no change in behavior.

1234567890 displays ok ----- why ?
1111111111 displays 11"1"1"1"1 ....
3333333333 displays 33'3'3'3'3....
aaaaaaaaaa displays aayayaya....
ababababab displays correct --- why ?

when repeating characters, the first 2 are always ok, and then always
the correct one, and a bad one.....

Mario

MarioAtJazz
LCD?
Posts: 4
Joined: Sat Feb 28, 2015 8:04 pm

Re: LK204-25 strange characters

Post by MarioAtJazz » Mon Mar 02, 2015 2:04 pm

It seems that hyperterm is the troublemaker.
with putty my tests are showing the right characters - strange.

Thank you ...

Clark
Matrix Orbital
Matrix Orbital
Posts: 861
Joined: Fri Aug 17, 2007 10:58 am
Location: Matrix Orbital
Contact:

Re: LK204-25 strange characters

Post by Clark » Mon Mar 02, 2015 2:12 pm

Hi Mario,

Good to hear you were able to resolve the issue by using a different program. If you have any further questions regarding that unit, please don't hesitate to post.

Cheers,
Troy
Troy Clark
Design & Development
Matrix Orbital

Post Reply

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests