Search found 27 matches

by TimVukman
Fri Apr 30, 2010 2:05 pm
Forum: MOC/MOS/MOI/MOU/X-Board/MOP
Topic: MOI-AL-202 with XBoard I2C help request
Replies: 12
Views: 10755

Got it!!!!!

Hi: I think I might have created an unwanted post on your forum. Please check and delete. It might just be blank. I'll have a look in a minute. Ok. I have the display working from my Arduino. The main issue was in my code in that I was always sending the 0xFE. That of course put the display in comma...
by TimVukman
Fri Apr 30, 2010 1:15 pm
Forum: MOC/MOS/MOI/MOU/X-Board/MOP
Topic: MOI-AL-202 with XBoard I2C help request
Replies: 12
Views: 10755

Hi: I have made progress. As stated in previous posts, when looking at the I2C bus with the Diolan U2C-12, I was seeing addresses of 0x7F and 0x28. I have used address 0x7F in their software and selected "open device". At this point, with a memory address length of 1, and a memory address of 0x00, I...
by TimVukman
Fri Apr 30, 2010 12:02 pm
Forum: MOC/MOS/MOI/MOU/X-Board/MOP
Topic: MOI-AL-202 with XBoard I2C help request
Replies: 12
Views: 10755

Hi Raquel: Changing the address to 50 made no difference. Unfortunately it does make me question the value of the Diolan U2C-I2 I have been relying on. I expected that the device reported the addresses it saw on the bus. Originally it indicated 7F which I took to be the Arduino and 0x28 which I beli...
by TimVukman
Fri Apr 30, 2010 9:57 am
Forum: MOC/MOS/MOI/MOU/X-Board/MOP
Topic: MOI-AL-202 with XBoard I2C help request
Replies: 12
Views: 10755

Good Morning Troy: Thanks for your suggestions. I will give those a go and report back. The begin.Transmission function is supposed to do the actions to start I2C. I believe that is the transition of SDA from high to low. I don't think they do anything more than that. I am concerned only in that I h...
by TimVukman
Thu Apr 29, 2010 2:04 pm
Forum: MOC/MOS/MOI/MOU/X-Board/MOP
Topic: MOI-AL-202 with XBoard I2C help request
Replies: 12
Views: 10755

Hi: Still no luck. I discovered this morning that I2C on the Arduino uses Analog Pin4 and Pin5. All day yesterday I was using Digital Pin4 and Pin5. That was a pretty good waste of time. Today I am on the right pins. I also connected my Diolan monitor to the SDA and SCL pins on the display itself. I...
by TimVukman
Wed Apr 28, 2010 4:00 pm
Forum: MOC/MOS/MOI/MOU/X-Board/MOP
Topic: MOI-AL-202 with XBoard I2C help request
Replies: 12
Views: 10755

Hi Troy: Still no magic, but I am updating a library for the Arduino that will hopefully get me where I need to get. I know I did all the code at the low level the last time, so I hope the library will be quicker in the end. When done, would you like copies of the .h, .cpp and Arduino sketch? Your a...
by TimVukman
Wed Apr 28, 2010 11:33 am
Forum: MOC/MOS/MOI/MOU/X-Board/MOP
Topic: MOI-AL-202 with XBoard I2C help request
Replies: 12
Views: 10755

** Not a Matrix Issue - User Problem - Code **

Hi Troy: Thanks for your reply. This morning I found my previous post on this forum from some time ago when I first got this display. In reading that post, I was reminded about 7 bit vs 8 bit I2C addresses. On that basis, the actual address for this display is 0x28. I hooked up a device I bought som...
by TimVukman
Tue Apr 27, 2010 6:11 pm
Forum: MOC/MOS/MOI/MOU/X-Board/MOP
Topic: MOI-AL-202 with XBoard I2C help request
Replies: 12
Views: 10755

MOI-AL-202 with XBoard I2C help request

Hi: I am trying to get this combination to work with my Arduino Diecimila. I am not expecting you to help me on the Arduino side, but it has been some time since I have worked with this display and I suspect that I am doing something wrong. I am looking in the MOX.pdf manual and on Page 14 it indica...
by TimVukman
Thu Oct 16, 2008 5:22 pm
Forum: MOC/MOS/MOI/MOU/X-Board/MOP
Topic: AL202C
Replies: 14
Views: 15441

Thank you:

That is the confirmation I was looking for.

Which display would you recommend? I would probably want to stick with Red but I guess anything would good readability and I2C would be fine.

I will look over the site tonight.

Tim
by TimVukman
Wed Oct 15, 2008 5:45 pm
Forum: MOC/MOS/MOI/MOU/X-Board/MOP
Topic: AL202C
Replies: 14
Views: 15441

Hi Raquel: Thanks for your note. I appreciate the code. That is most kind of you. Can I use Large characters and regular characters at the same time? It would be nice to have 4 large characters for the numbers for the clock on half the display and then regular text for date and day of the week and a...
by TimVukman
Wed Oct 15, 2008 5:00 pm
Forum: MOC/MOS/MOI/MOU/X-Board/MOP
Topic: AL202C
Replies: 14
Views: 15441

Hi Troy: I guess what I was looking for was a little more detailed on the pixel level. For example, when writing 5x8 characters, there is a space between the characters. I am assuming that there are no active pixels in this space. I would similarily assume that there are no active pixels between the...
by TimVukman
Tue Oct 14, 2008 4:36 pm
Forum: MOC/MOS/MOI/MOU/X-Board/MOP
Topic: MOP-AL404C backlight question
Replies: 7
Views: 8743

Hi Troy Lets drop this thread and stick with the AL202 since I have temporarily shelved the 404C It is entirely possible that there is enough space available for me on the AL202 to do what I would like. I did read something about reserving bank 0 for the splash screen. If I don't want a splash scree...
by TimVukman
Tue Oct 14, 2008 4:30 pm
Forum: MOC/MOS/MOI/MOU/X-Board/MOP
Topic: AL202C
Replies: 14
Views: 15441

Thanks Troy: I am certainly interested in the advanced font kind of stuff. If I could fake a split screen to get full size characters I would be most pleased. I did put it on hold for the weekend to focus on getting everything running before I started playing around. Saturday was very frustrating as...
by TimVukman
Fri Oct 10, 2008 4:45 pm
Forum: MOC/MOS/MOI/MOU/X-Board/MOP
Topic: AL202C
Replies: 14
Views: 15441

Hi Troy: Amazing things happen when you use the correct address. My display is working perfectly and all I changed were two characters. I'm still kicking myself. Perhaps you might have some advise on the subject of characters. Ideally, I would like to used the left half of the display in medium mode...
by TimVukman
Fri Oct 10, 2008 10:22 am
Forum: MOC/MOS/MOI/MOU/X-Board/MOP
Topic: AL202C
Replies: 14
Views: 15441

Ray: Thank you so much for the Arduino link. I have been going through the site in detail as I was working on try to get a parallel display up before I switched to this new display. I tried both the 4bit and 8bit libraries. The 4 bit worked and I got garbage. The 8bit worked great but I really wante...